분류없음2011.12.28 09:16
  이번 글은 JDK5(1.5)와 JDK6(1.6)의 설치방법입니다.
원래는 Android 컴파일 환경 구축을 위한 글에 있었는데, 다른 글에서도 사용할 필요가 있어서 별도로 뺐습니다.
아래 명령어대로 설치하시면 되는데, 중간에 나오는 확인 창은 탭키를 누르시면 선택하실 수 있습니다.

※ JDK5 설치
- JDK5 설치 명령어

$ sudo apt-get install sun-java5-jdk


- JDK5 패키지 못 찾는다고 할 경우 아래 명령어 입력

$ sudo add-apt-repository "deb http://kr.archive.ubuntu.com/ubuntu/ jaunty multiverse"

$ sudo add-apt-repository "deb http://kr.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse"

$ sudo apt-get update

jaunty(Ubuntu 9.04)에 대한 지원이 끊기면서 아래 주소를 이용해야 합니다.

$ sudo add-apt-repository "deb http://www2.frugalware.org/mirror/old-releases.ubuntu.com/ubuntu/ jaunty multiverse"

$ sudo add-apt-repository "deb http://www2.frugalware.org/mirror/old-releases.ubuntu.com/ubuntu/ jaunty-updates multiverse"

$ sudo apt-get update


hardy(Ubuntu 8.04 같음)는 아직 지원하나 보네요. (2012-04-26 변경)

$ sudo add-apt-repository "deb http://ftp.daum.net/ubuntu hardy main multiverse"

$ sudo add-apt-repository "deb http://ftp.daum.net/ubuntu hardy-updates main multiverse"

$ sudo apt-get update


※ JDK6 설치 
- JDK6 설치 명령어

$ sudo apt-get install sun-java6-jdk


- JDK6 패키지 못 찾는다고 할 경우 아래 명령어 입력

$ sudo add-apt-repository "deb http://archive.canonical.com/ lucid partner"

$ sudo add-apt-repository "deb-src http://archive.canonical.com/ubuntu lucid partner"

$ sudo apt-get update


JDK6에 대한 지원도 끊긴 것 같습니다.. (2012-05-24 변경)

Package sun-java6-jdk has no installation candidate 메시지 뜰 경우 아래 이용해주세요

$ sudo add-apt-repository ppa:ferramroberto/java

$ sudo apt-get update


- "add-apt-repository: command not found" 못 찾는다고 할 경우 아래 설치

$ sudo apt-get install python-software-properties


※ JDK 버전 변경

http://blog.naver.com/makin/94102105

신고
Posted by 황타

티스토리 툴바